Slow Performance of Matrix Booking system

Incident Report for Matrix Booking

Resolved

The system is now operational.
Posted Mar 05, 2024 - 09:46 UTC

Update

We are continuing to investigate this issue.
Posted Mar 05, 2024 - 09:25 UTC

Investigating

We are currently investigating reports of slow performance of the Matrix Booking platform
Posted Mar 05, 2024 - 09:24 UTC
This incident affected: Web applications, Mobile applications, Email delivery service, API service, Matrix Welcome apps (inc Digital Signage), Office 365 Calendar Integration, and Outlook .net AddIn.