Slow Performance of Matrix Booking system

Incident Report for Matrix Booking

Postmortem

On the morning of the 16th of April 2024, the Matrix Booking platform suffered from degraded performance during peak times which resulted in an increase in the time it was taking for users to perform key tasks.

At around 9:15am the system alerted the team to an increase in response times from the Matrix Booking platform and an investigation uncovered that the system was under heavy load. Monitoring determined the scale of the issue had increased and at 9:30am it was decided to initiate a fail over. As a result of work undertaken following last weeks issues, the fail over took place with no downtime and as a result we started to see an improvement in performance immediately and the system performance returned to normal operational parameters by 9:45am.

We sincerely apologise for any inconvenience this caused.

We continue to investigate the underlying issues that resulted in the degradation of the system performance as a priority.

Posted Apr 17, 2024 - 17:03 UTC

Resolved

The system performance is back to normal.
Posted Apr 16, 2024 - 09:14 UTC

Update

We are continuing to investigate this issue.
Posted Apr 16, 2024 - 08:37 UTC

Investigating

We are currently investigating performance issues on
Posted Apr 16, 2024 - 08:36 UTC
This incident affected: Web applications, Mobile applications, Email delivery service, API service, Matrix Welcome apps (inc Digital Signage), Office 365 Calendar Integration, and Outlook .net AddIn.