Some O365 calendars losing synchronisation

Incident Report for Matrix Booking

Postmortem

We believe that as a result of our release in June 2022, the act of releasing the new software triggered a restart of part of our infrastructure. This in turn triggered a minor point upgrade to be downloaded and auto installed (for security reasons). This minor change impacted the way our O365 Calendar Integration triggers synchronisation and where a trigger had previously accepted JSON format it no longer did and only accepted text. This meant that from that point onwards when customer subscriptions expire and need to be renewed (this normally happens in the background every two days) then the re-subscribe was failing, and from that point onwards any changes to O365 calendars was not being fed to Matrix Booking. The issue was identified very quickly and a hot fix release on Monday 27th to address this. From that point the issue had been resolved and any calendar changes where now fully synchronised.

However there was still the period (mostly during Monday 27th June) where changes made had not been synchronised.

All these changes that were missed have now been synchronised fully and all calendars are up to date and synchronising as normal. We will continue to monitor this and also review to identify any other learning points or changes made / required to prevent or mitigate this in the future.

Posted Jul 05, 2022 - 12:44 UTC

Resolved

A minor change in one of our releases caused some of the organisations with O365 Calendar Integration to lose this synchronisation. So for a period of time (from Friday 24th June to Monday 27th June 2022) changes made in Office 365 where not automatically or immediately synchronised with Matrix Booking.
Posted Jun 24, 2022 - 14:00 UTC